PayU (v2.4) plugin for LaraClassifier and JobClass.

PayU (v2.4) plugin for LaraClassifier and JobClass.
Артикул: lc-payu
Старая цена: 379,50 ₽
316,25 ₽
Доставить в
*
*
Спопсоб доставки
Название
Ориентировочная дата доставки
Цена
Нет способов доставки

PayU (v2.4) plugin for LaraClassifier and JobClass.

Installation

To install this plugin:

  • Copy the plugin's (uncompressed) folder into the script's plugins folder like this: /extras/plugins/payu/
  • Go to your Admin panel → Plugins (and click on "Install") to install it.

Compatibility

  • v2.4 => LaraClassifier v11.0.0+ and JobClass v10.0.0+
  • v2.3 => LaraClassifier v10.2.0+ and JobClass v9.2.0+
  • v2.2 => LaraClassifier (v10.1.2 to v10.1.4) and JobClass (v9.1.3 to v9.1.5)
  • v2.1 => LaraClassifier (v10.0.0 to v10.1.1) and JobClass (v9.0.0 to v9.1.2)
  • v2.0 => LaraClassifier (v9.0.0 to v9.0.1) and JobClass (v8.0.0 to v8.0.1)
  • v1.9 => LaraClassifier (v8.0.2 to v8.0.6) and JobClass (v7.0.2 to v7.0.6)
  • v1.8 => LaraClassifier (v8.0.0 to v8.0.1) and JobClass (v7.0.0 to v7.0.1)
  • v1.7 => LaraClassifier (v7.1.x to v7.3.8) and JobClass (v5.9.x to v6.1.8)
  • v1.6 => LaraClassifier (v6.6.x to v7.0.x) and JobClass (v5.4.x to v5.8.x)
  • v1.5 => LaraClassifier (v5.7 to v6.5) and JobClass (v4.5 to v5.3)
  • v1.4 => LaraClassifier (v5.2 to v5.6) and JobClass (v4.0 to v4.4)
  • v1.3 => LaraClassifier v5.1 and JobClass v3.9
  • v1.2 => LaraClassifier (v4.9 to v5.0) and JobClass (v3.7 to v3.8)
  • v1.0 to v1.1 => LaraClassifier (v3.1 to v4.8) and JobClass (v2.0 to v3.6)

Update

Replace all the plugin's files on your server.

Configuration

SDK supports two PayU OAuth grant types: client_credentials and trusted_merchant. Default is client_credentials.

Parameters needed for client_credentials

Add the settings below in the script's /.env file on your server:

PAYU_MODE=your-payu-mode
PAYU_POS_ID=your-payu-merchant-pos-id
PAYU_SECOND_KEY=your-payu-second-key
PAYU_OAUTH_CLIENT_SECRET=your-payu-oauth-client-secret
    

NOTE: The PAYU_MODE variable can be sandbox (for your sandbox account testing) or live (for your live or real account).

Parameters needed for trusted_merchant

Add the settings below in the script's /.env file on your server:

PAYU_MODE=your-payu-mode
PAYU_POS_ID=your-payu-merchant-pos-id
PAYU_SECOND_KEY=your-payu-second-key
PAYU_OAUTH_CLIENT_SECRET=your-payu-oauth-client-secret
PAYU_OAUTH_GRANT_TYPE=trusted_merchant
PAYU_OAUTH_EMAIL=your-payu-oauth-email
PAYU_OAUTH_EXT_CUSTOMER_ID=your-payu-oauth-ext-customer-id
    

NOTE: The PAYU_MODE variable can be sandbox (for your sandbox account testing) or live (for your live or real account).

Connection over Proxy

Add the settings below in addition in the script's /.env file.

PAYU_PROXY_HOST=your-payu-proxy-host
PAYU_PROXY_PORT=your-payu-proxy-port
PAYU_PROXY_USER=your-payu-proxy-user
PAYU_PROXY_PASSWORD=your-payu-proxy-password
    

Translation

To translate this plugin into your language:

  • Go to the languages folder at /extras/plugins/payu/lang/
  • Duplicate the folder /extras/plugins/payu/lang/en/ to /extras/plugins/payu/lang/<abbr>/
    NOTE: Don't forget replace <abbr> by your language code (e.g. "de" for German language).
  • Open the file /extras/plugins/payu/lang/<abbr>/messages.php and translate it.
    NOTE: To translate the file, you must change the values and not the keys of PHP array.

Uninstallation

To uninstall this plugin, go to your Admin panel → Plugins (and click on "Uninstall") to uninstall it.

Removing

To remove this plugin:

  • Uninstall it
  • Go in the folder /extras/plugins/ and remove the folder payu/.

Resources