Stripe (v2.7) plugin for LaraClassifier and JobClass.

Stripe (v2.7) plugin for LaraClassifier and JobClass.
Артикул: lc-stripe
Старая цена: 379,50 ₽
316,25 ₽
Доставить в
*
*
Спопсоб доставки
Название
Ориентировочная дата доставки
Цена
Нет способов доставки

Stripe (v2.7) plugin for LaraClassifier and JobClass.

Installation

To install this plugin:

  • Copy the plugin's (uncompressed) folder into the script's plugins folder like this: /extras/plugins/stripe/
  • Go to your Admin panel → Plugins (and click on "Install") to install it.

Compatibility

  • v2.7 => LaraClassifier v11.0.0+ and JobClass v10.0.0+
  • v2.6 => LaraClassifier v10.2.0+ and JobClass v9.2.0+
  • v2.5 => LaraClassifier v10.2.0 and JobClass v9.2.0
  • v2.4 => LaraClassifier (v10.0.1 to v10.1.4) and JobClass (v9.0.1 to v9.1.5)
  • v2.3 => LaraClassifier v10.0.1 and JobClass v9.0.1
  • v2.2 => LaraClassifier v10.0.1 and JobClass v9.0.1
  • v2.1 => LaraClassifier v10.0.0 and JobClass v9.0.0
  • v2.0 => LaraClassifier (v9.0.0 to v9.0.1) and JobClass (v8.0.0 to v8.0.1)
  • v1.9 => LaraClassifier (v8.0.2 to v8.0.6) and JobClass (v7.0.2 to v7.0.6)
  • v1.8 => LaraClassifier (v7.1.0 to v8.0.1) and JobClass (v5.9.0 to v7.0.1)
  • v1.7 => LaraClassifier (v6.6 to v7.0.4) and JobClass (v5.4 to v5.8.4)
  • v1.6 => LaraClassifier (v5.7 to v6.5) and JobClass (v4.5 to v5.3)
  • v1.5 => LaraClassifier (v5.2 to v5.6) and JobClass (v4.0 to v4.4)
  • v1.4 => LaraClassifier v5.1 and JobClass v3.9
  • v1.3 => LaraClassifier (v4.9 to v5.0) and JobClass (v3.7 to v3.8)
  • v1.1 to v1.2 => LaraClassifier (v3.1 to v4.8) and JobClass (v2.0 to v3.6)
  • v1.0 => LaraClassifier v3.0 and JobClass v1.9

Update

Replace all the plugin's files on your server.

Configuration

Add the settings below in the script's /.env file on your server:

STRIPE_KEY=
STRIPE_SECRET=
    

Example of use:

STRIPE_KEY=your-stripe-key
STRIPE_SECRET=your-stripe-secret
    

NOTE:

  • Integration modes supported: checkout and payment_intent.
  • To select an integration mode you have to use the variable STRIPE_INTEGRATION= in the /.env file like this: STRIPE_INTEGRATION=payment_intent.
  • Without adding the STRIPE_INTEGRATION= variable in the /.env, the default integration is checkout.
  • In order to use checkout integration, you must set an account or business name at https://dashboard.stripe.com/account.

Translation

To translate this plugin into your language:

  • Go to the languages folder at /extras/plugins/stripe/lang/
  • Duplicate the folder /extras/plugins/stripe/lang/en/ to /extras/plugins/stripe/lang/<abbr>/
    NOTE: Don't forget replace <abbr> by your language code (e.g. "de" for German language).
  • Open the file /extras/plugins/stripe/lang/<abbr>/messages.php and translate it.
    NOTE: To translate the file, you must change the values and not the keys of PHP array.

Uninstallation

To uninstall this plugin, go to your Admin panel → Plugins (and click on "Uninstall") to uninstall it.

Removing

To remove this plugin:

  • Uninstall it
  • Go in the folder /extras/plugins/ and remove the folder stripe/.

Resources